Pré-requisitos

GLPI é um aplicativo da Web que precisará:

  • um servidor web;
  • PHP;
  • um banco de dados.

Servidor Web

GLPI requer um servidor web que ofereça suporte a PHP, como:

PHP

A partir da versão 9.5, o GLPI requer PHP <http://php.net> _ 7.2 ou mais recente.

Nota

Recomendamos o uso da versão estável do PHP mais recente para obter melhores desempenhos.

Extensões obrigatórias

As seguintes extensões PHP são necessárias para que o aplicativo funcione corretamente:

  • curl: para autenticação CAS, verificação de versão do GLPI, Telemetria, etc;
  • fileinfo: para obter informações extras dos arquivos;
  • gd: para gerar imagens;
  • json: para obter suporte para o formato de dados JSON;
  • mbstring: gerenciar caracteres multibytes;
  • mysqli: para conectar e consultar o banco de dados;
  • session: para obter suporte a sessões de usuários;
  • zlib: para efetuar backup e restaurar as funções da base de dados;
  • simplexml;
  • xml;
  • intl.

Extensões opcionais

Nota

Mesmo que essas extensões não sejam obrigatórias, recomendamos que você as instale de qualquer maneira.

As seguintes extensões PHP são necessárias para alguns recursos extras do GLPI:

  • cli: usar o PHP a partir da linha de comando (scripts, ações automáticas, etc.);
  • domxml: usado para autenticação CAS;
  • ldap: usar o diretório LDAP para autenticação;
  • openssl: comunicações seguras;
  • `` xmlrpc``: usado para a API XMLRPC.
  • APCu`: pode ser usado para cache; entre outros (veja configuração de caching (somente em francês) <http://glpi-user-documentation.readthedocs.io/fr/latest/advanced/cache.html>

Configuração

O arquivo de configuração do PHP (php.ini) pode ser adaptado para refletir as seguintes variáveis:

memory_limit = 64M ;        // max memory limit
file_uploads = on ;
max_execution_time = 600 ;  // not mandatory but recommended
session.auto_start = off ;
session.use_trans_sid = 0 ; // not mandatory but recommended

Banco de dados

Aviso

Atualmente, apenas os servidores de banco de dados MySQL <https://dev.mysql.com> _ (5.6 mínimo) e MariaDB <https://mariadb.com> _ (10.0 mínimo) são suportados pelo GLPI.

Para funcionar, o GLPI requer um servidor de banco de dados.

Creative Commons License